Category: General
-
Microsoft XDR Hunting Query – Email Threats
This KQL script provides graphical analysis of email threats in your environment. It uses EmailAction to identify ThreatTypes such as Malware, Phish and Quarantine. It then shows you graphically how many email threats are present and you can use the time parameter to adjust the timespan. let Threshold = 50; EmailEvents | where EmailAction ==…
-
Fog Project – Capture and Deployment
This document will outline a basic process of capturing an image from a host PC and deploy it to a different PC on the network. You must ensure that network boot is at the top of the boot sequence in order to allow the PC(s) to find the Fog Server when capturing and deploying. For…
-
Active Directory OU Export to CSV File
This command will allow you to export a list of devices in specific OUs to a CSV file. Open PowerShell as an Administrator and run this command: Get-ADComputer -SearchScope Subtree -SearchBase “OU=Room,OU=Building,OU=Staff,OU=Workstations,DC=Domain,DC=co,DC=uk” -Filter * -Properties Name | Export-Csv -Path “c:\Exported_Device_List.csv” You will need to specify the properties of the OU you want to export. The…
-
Active Directory Basics
This is only a short list of basics that I use to navigate around Active Directory and administrate machines on a daily basis. Working with Active Directory can be confusing if you don’t know your way round your domain so it’s best to stay away from areas you do not administer. Searching for an Asset…
-
Jamf – Management Commands Stuck as Pending
If a device has pending commands in the Management tab type: sudo profiles renew -type enrollment This solves issues with configuration profiles and policies not falling down to devices. Once the command is executed you can run: sudo jamf recon This will then instantly reach for any policies or configuration profiles that are pending and…
-
Mac OS Fundamentals
This page provides a cheat cheat for mac OS. I use these commands regularly when testing, installing and developing solutions on Mac OS projects. File & Directory Commands Command Description defaults write com.apple.Finder AppleShowAllFiles true && killall Finder Enable the setting to view hidden files in finder from CLI ls Lists directory contents. ls -l…
-
Google Chrome History
This is a script I use to pull down browser history from accounts on PCs. I use this script to check on how user accounts are being used by students and staff to ensure devices are being used for work and not personal use. You need to change “USERNAME” to a user name found in:…
-
How to Deploy Unreal Engine
This document outlines the process of downloading and deploying Unreal Engine. This process outlines the steps you need to create the installer and the script required to deploy the software. Please be aware that the script requires editing depending on the version you extract. Note: I have used this process to deploy versions 4 and…
-
iPad & iPhone Deployment – Manual Jamf Enrollment
This documentation provides steps on manually enrolling iPads & iPhones in Jamf. This is setup using Apple Configurator 2. Creating Packages Log in to Jamf Pro and go to Mobile Device – Enrollment Profile Note: You will have two downloads will start. Cancel both of them when they try to install onto your Mac. You just…
-
Build and Configure Chilipie Kiosk – Raspberry Pi
I tested this project on a Raspberry Pi 4 Model B. I use this as a kiosk to display webpages, search engines and home automation but with limited access to anything else. This tutorial provides a basic tutorial on how to get the Raspberry Pi setup with Chilipie and configure the basics. You can however…
-
How to Extract a MSI from an EXE
This is quite a simple process. I use it all the time during the application deployment process. I like to have access to both versions of an installer incase I find that the original MSI file does not deploy correctly, or if I need to configure some parameters using switches. Using this method allows you…
-
Install ROS Kinetic for Ubuntu
This set of instructions is for installing ROS Kinetic. It was tested on Ubuntu 20.04. ROS Installation Configuration Setup your sources.list Installation of ROS There are even more packages available in ROS. You can always install a specific package directly. apt search ros-noetic Environment setup source /opt/ros/noetic/setup.bash It can be convenient to automatically source this…
